The i3 FAQ has migrated to https://www.reddit.com/r/i3wm/. All content here is read-only.
Ask Your Question
0

Applets missing

asked 2015-07-16 21:16:01 +0000

nielsk gravatar image

After an absence of a couple of months using i3, no applets are anymore in my status bar. Even when I start them manually (like nm-applet) they do not appear. I already tried resizing my status bar from what I read in other threads but this didn't help. Any ideas?

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
2

answered 2015-07-17 04:47:51 +0000

i3convert gravatar image

What is likely to be missing is the system tray. In your config file, in the i3bar configuration section (bar { ... }), search for the tray_output directive. This directive specifies if the system tray should be displayed and on what output.

You may want to experiment a little bit. In particular you can try the following if you find a directive

  • tray_output none: Try deleting it.
  • tray_output primary: Make sure the current screen is primary by running xrandr --output <output> --primary, where <output> is your current output.
  • tray_output <output>, where <output> is not your current output: Modify it to your current output.

More information can be found in the i3 User's Guide in Section 5.8. Tray Output.

edit flag offensive delete link more

Comments

Thanks a lot. For whatever reason my primary output wasn't set correctly. I guess the switch to lightdm some time ago might be the reason for the problem

nielsk gravatar imagenielsk ( 2015-07-18 11:13:12 +0000 )edit

Question Tools

1 follower

Stats

Asked: 2015-07-16 21:16:01 +0000

Seen: 154 times

Last updated: Jul 17