The i3 FAQ has migrated to https://www.reddit.com/r/i3wm/. All content here is read-only.
Ask Your Question
2

Disable titlebar completely

asked 2013-11-12 07:30:36 +0000

gulver gravatar image

updated 2013-11-12 07:37:38 +0000

Hi there,

I would like to get rid of the title-bars completely. I work mostly by workspaces and I don't want to see any title, don't wanna hear, don't wanna read.

I know of border none assignation and read about bb command but the first is useless in my case and I'm yet to figure out how to use bb command in config if that is even possible in this case.

Maybe with a script?

Thanks

edit retag flag offensive close merge delete

Comments

Good question. I have configured my system with 'bindsym $mod+b border toggle', but it would still be awesome to set a default behavior What.

cee gravatar imagecee ( 2013-11-12 08:51:10 +0000 )edit

`bb` is no longer a command in i3 since version 4.0. Use `border none` instead.

Adaephon gravatar imageAdaephon ( 2013-11-12 19:51:43 +0000 )edit

3 answers

Sort by ยป oldest newest most voted
2

answered 2013-11-12 10:11:16 +0000

Adaephon gravatar image

updated 2013-11-13 20:51:45 +0000

Add this to your configuration (replace any existing new_window if necessary):

new_window 1pixel

See here for more information.

This will set borders on new windows to 1pixel if they are in a split container. In stacked or tabbed containers the title bar(s) will still be shown if there is more than one window in the container.

edit flag offensive delete link more

Comments

I have set 'new\_window none' on top of my config (the only place in the whole file) and also set 'new\_float none'. It does not seem to change anything. Any new window is shown with 'normal' border. i3 version 4.6

cee gravatar imagecee ( 2013-11-12 10:33:24 +0000 )edit

Same here problem with cee. I've tried both already; Is this solution something you are making use of or ever observed as correctly working?

gulver gravatar imagegulver ( 2013-11-12 12:41:46 +0000 )edit

No I do not use this myself, but I tested it before posting. And it works just like calling `border 1pixel` on every new window would, it removes the title bar. At least on windows in split containers. It seems that tabbed and stacked containers keep their title bar(s) no matter what you set.

Adaephon gravatar imageAdaephon ( 2013-11-12 19:48:56 +0000 )edit

It doesn't completely disables titlebar yet that's as close as it gets till a new release comes. I'll mark this as solved to thank you.

gulver gravatar imagegulver ( 2013-11-13 13:42:34 +0000 )edit

Thanks heaps, Adaephon!

paramnesioid gravatar imageparamnesioid ( 2013-12-28 07:08:04 +0000 )edit
0

answered 2013-12-28 07:12:54 +0000

paramnesioid gravatar image

updated 2013-12-29 14:22:57 +0000

This works for me: for_window [class="^.*"] border pixel 1

edit flag offensive delete link more
0

answered 2013-11-14 14:42:44 +0000

TonyC gravatar image

It's a little hacky, but you can get this by setting your font size to zero

font pango:DejaVu Sans Mono 0

which renders a ~5px titlebar with no text. For me, that is better than having the titlebar completely disabled because you get an indication of the active window.

edit flag offensive delete link more

Comments

This disables the bottom bar as well

YetAnotherAccount gravatar imageYetAnotherAccount ( 2015-10-01 08:20:52 +0000 )edit

Question Tools

Stats

Asked: 2013-11-12 07:30:36 +0000

Seen: 14,531 times

Last updated: Dec 29 '13