The i3 FAQ has migrated to https://www.reddit.com/r/i3wm/. All content here is read-only.
Ask Your Question
0

A strange window title like "i3: S[Navigator]"

asked 2014-01-01 21:54:31 +0000

anonymous user

Anonymous

By changing the layout of the windows I sometimes end up with a window (probably a container in the i3 nomenclature) that in the title reads something like "i3: S[Navigator]". After reading all the documentation I still cannot figure out how this comes up. Could someone explain the behaviour and perhaps advise how to avoid this awkward set-up.

Jacek

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
4

answered 2014-01-02 11:54:56 +0000

cee gravatar image

That means that your container has a "stacked layout" (mod+s) and within your container there is one program (Navigator) displayed.
If you would start another program (say urxvt) within your stacked container the title would be something like: "i3: S[Navigator urxvt]".
You can switch the focus between the different containers within your stacked container with mod+<arrow_keys> (or whatever you have put in your config file).

There is also the option to make the main container horizontally split or tabbed. The state is displayed in the title with "i3: H[Navigator urxvt]" or "i3: T[Navigator urxvt]" respectively.

edit flag offensive delete link more

Comments

Thank you for the explanation. I've just come across the screencast on containers and trees within i3. It seems I get it.

bonidydy gravatar imagebonidydy ( 2014-01-02 20:41:01 +0000 )edit
cee gravatar imagecee ( 2014-01-03 06:51:37 +0000 )edit

So how can I collapse multiple Navigators, or make them go away? I don't know how I did it, but I ended up with 4 navigators navigating my Firefox. I'd rather just have a plain old application window, but I am embarrassed to say the only way I know how to achieve this is to restart Firefox itself :(

Alice gravatar imageAlice ( 2014-12-25 11:45:52 +0000 )edit
0

answered 2015-01-22 07:33:16 +0000

jefbed gravatar image

Switch the window's desktop with <mod>-Shift-<number>, switch to the desktop <number>, then move the window back to the original desktop--the navigator should be gone.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2014-01-01 21:54:31 +0000

Seen: 981 times

Last updated: Jan 22