The i3 FAQ has migrated to https://www.reddit.com/r/i3wm/. All content here is read-only.
Ask Your Question
2

i3bar disable scrolling

asked 2012-10-06 02:09:10 +0000

coderarity gravatar image

When I scroll in the i3bar at the bottom of my i3wm, it changes my workspace. How can I disable that behavior? Thanks!

edit retag flag offensive close merge delete

Comments

I'm also looking for a way to disable this changing workspace with the mousewheel. My new wheel's mouse is so sensitive than the workspaces change when I didn't asked for (the wheel is continuing to roll during several second after finger action). An option could be usefull.

Spheerys gravatar imageSpheerys ( 2013-08-14 14:31:41 +0000 )edit

3 answers

Sort by » oldest newest most voted
3

answered 2013-10-14 15:47:53 +0000

SexyBachelor gravatar image

updated 2015-10-11 10:16:19 +0000

Michael gravatar image

For anyone else interested, I've made a feature request (follow the link below). We should discuss in more detail (if needed) on the feature request.

https://github.com/i3/i3/issues/1104

edit flag offensive delete link more

Comments

I would upvote you, but I don't even have enough points to do that.

BatmanAoD gravatar imageBatmanAoD ( 2013-10-14 16:27:59 +0000 )edit

@BatmanAoD haha yeah the points are a bit silly for a faq :/

SexyBachelor gravatar imageSexyBachelor ( 2013-10-15 15:42:44 +0000 )edit

@SexyBachelor Wait to have enough karma, which will come pretty quickly and you'll get the chance to insert the link. Just be patient ;-)

syl20bnr gravatar imagesyl20bnr ( 2013-10-18 01:44:50 +0000 )edit
0

answered 2013-12-19 04:39:03 +0000

TonyC gravatar image

Put your bar on the top of the screen with position top and you will never accidentally scroll your workspaces again.

edit flag offensive delete link more
-1

answered 2012-10-06 10:03:38 +0000

Michael gravatar image

You can’t, currently. I’m also not sure whether we should make that configurable at all. What’s the rationale for disabling it? You could just not scroll there, right?

edit flag offensive delete link more

Comments

I can give one: this happened many times with me because I was actually scrolling a document/page too close to the bottom (the scrollbar button is veryclose to i3bar I reckon)...

bruno.braga gravatar imagebruno.braga ( 2012-10-09 14:56:46 +0000 )edit

for what it is worth, I am here because I am running arch/i3wm in a virtualbox guest and the scroll wheel is acting strangely, sometimes changing workspaces when far from the workplace switcher. I figured I'd just disable the functionality all together.

i3wmtempcomment gravatar imagei3wmtempcomment ( 2013-07-15 16:18:04 +0000 )edit

I'd like to disable this because I'm currently using i3 on a laptop with a touchscreen. After I use the touchscreen for something the next action with the touchpad move the cursor to the bottom of the screen, so I don't necessarily know that I'll be scrolling over the bar.

qqx gravatar imageqqx ( 2013-08-27 05:03:01 +0000 )edit

Please disable the mouse scroll on the i3bar, it is very annoying as previous comments explained.

phairland gravatar imagephairland ( 2013-09-15 07:06:36 +0000 )edit

Can any of you please open a feature request on https://github.com/i3/i3/issues for that? Or just submit a pull request directly? :) The faq is not a site where we track feature requests and I just stumbled upon these comments by accident.

Michael gravatar imageMichael ( 2013-09-15 19:12:13 +0000 )edit

Question Tools

1 follower

Stats

Asked: 2012-10-06 02:09:10 +0000

Seen: 1,457 times

Last updated: Oct 11