The i3 FAQ has migrated to https://www.reddit.com/r/i3wm/. All content here is read-only.
Ask Your Question
0

Can't install i3 4.11 on Ubuntu 14.04

asked 2015-11-01 23:23:03 +0000

fahs23 gravatar image

Hi guys,

I get the following error-message when trying installing i3 through provided repositories for Debian and Ubuntu on http://i3wm.org

The following packages have unmet dependencies:
i3 : Depends: i3-wm (= 4.11-1~~trusty1) but it is not going to be installed
Recommends: i3lock (>= 2.2) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I hope someone can help me solve this problem.

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
2

answered 2015-11-15 17:14:41 +0000

oldos2er gravatar image

Enable the http://debian.sur5r.net repository, then run

sudo apt-get update && sudo apt-get install i3

You might need to first run

sudo apt-get install -f

to fix your broken packages.

edit flag offensive delete link more

Comments

1

To clarify where this repository comes from and why it can be trusted. From the i3 documentation (http://i3wm.org/docs/repositories.html): "This Ubuntu repository is provided by sur5r and contains the latest stable release of i3."

apoc gravatar imageapoc ( 2015-11-15 17:27:40 +0000 )edit

Question Tools

Stats

Asked: 2015-11-01 23:23:03 +0000

Seen: 210 times

Last updated: Nov 15