The i3 FAQ has migrated to https://www.reddit.com/r/i3wm/. All content here is read-only.
Ask Your Question
1

How can I get rid of the nautilus desktop window?

asked 2012-06-04 13:07:44 +0000

this post is marked as community wiki

This post is a wiki. Anyone with karma >100 is welcome to improve it.

When using i3 within a GNOME session, starting nautilus (the file manager), nautilus will also start a window containing the desktop icons. This window is just a normal, managed window in i3.

To disable the nautilus desktop window, use:

$ gsettings set org.gnome.desktop.background show-desktop-icons false

On older systems, you can try:

gconftool-2 \                                                                   
--type bool \             
--set /apps/nautilus/preferences/show_desktop false
edit retag flag offensive close merge delete

Comments

hasn't fixed it for me :-(

Kretortex gravatar imageKretortex ( 2013-04-09 13:29:29 +0000 )edit

@Michael Wouldn't your answer be more clear if it was an actual accepted answer ? Nevertheless, thanks for the tip! It worked for me.

Yannick gravatar imageYannick ( 2013-10-04 15:35:42 +0000 )edit

4 answers

Sort by » oldest newest most voted
1

answered 2012-06-04 20:14:15 +0000

this post is marked as community wiki

This post is a wiki. Anyone with karma >100 is welcome to improve it.

Starting nautilus with --no-desktop also does the trick but this is not the permanent solution.

edit flag offensive delete link more
0

answered 2014-09-24 02:54:10 +0000

this post is marked as community wiki

This post is a wiki. Anyone with karma >100 is welcome to improve it.

This has stopped working on Ubuntu 14.04.

[UPDATED] Muhuahha, of course, after a couple of months suffering this, as soon as I post a question in a public forum, I find the answer myself. The problem is the new Ubuntu includes a fork of Nautilus called Nemo (just found out) and the config for nemo is different.

$ gsettings set org.nemo.desktop show-desktop-icons false

will do the trick.

edit flag offensive delete link more
0

answered 2012-06-06 00:27:54 +0000

this post is marked as community wiki

This post is a wiki. Anyone with karma >100 is welcome to improve it.

I also found that very annoying, and to type every time (from terminal) "nautilus --no-desktop" is a pain. Some things you can do about it (if you want to keep using nautilus):

(a) create a bash alias:

# add this to your ~/.bash_aliases file
alias N='nautilus --no-desktop&'

This works, but still you would need a terminal to execute this (and all nautilus output dirts your terminal). So, what I do it:

(b) create a bash script and place it in your $PATH:

create the file, let's say: nautilus2 or n2autilus in /usr/local/bin:

#!/bin/bash
nautilus --no-desktop

I like the n2autilus, because it is quick to access through the dmenu_run ($mod+d, then type n2, enter, and you are done).

edit flag offensive delete link more

Comments

Doesn’t the permanent solution I posted work?

Michael gravatar imageMichael ( 2012-06-06 04:26:29 +0000 )edit

Sorry Michael, it actually worked! Don't know why (maybe I did something wrong last time), but it did not work for me before. I think I only used gconftool instead of gsettings (the latter is the one that worked for me). Thanks for correcting it!

bruno.braga gravatar imagebruno.braga ( 2012-06-06 08:25:38 +0000 )edit
0

answered 2012-06-04 15:22:15 +0000

this post is marked as community wiki

This post is a wiki. Anyone with karma >100 is welcome to improve it.

I guess this is more a comment than an answer, but I can't find a comment box..

My question: Is this somehow applicable to XFCE and their desktop window?

edit flag offensive delete link more

Comments

There is a "post a comment" link on the bottom of each question/answer. Also, can you elaborate on when XFCE opens its desktop window? When i start thunar (the file manager), I only get a thunar window.

Michael gravatar imageMichael ( 2012-06-04 15:40:55 +0000 )edit

There is a "post a comment" link on the bottom of each question/answer.

Michael gravatar imageMichael ( 2012-06-04 15:40:55 +0000 )edit

Hm, when I'm logged out I see the comment link, but not if I'm logged in :/

kenda gravatar imagekenda ( 2012-06-04 15:55:17 +0000 )edit

The desktop window appears because I start a full "xfce4-session" from i3.

kenda gravatar imagekenda ( 2012-06-04 15:57:30 +0000 )edit

Thanks for the hint, I lowered the karma requirements for commenting.

Michael gravatar imageMichael ( 2012-06-04 16:01:12 +0000 )edit

Question Tools

Stats

Asked: 2012-06-04 13:07:44 +0000

Seen: 10,820 times

Last updated: Sep 24 '14