The i3 FAQ has migrated to https://www.reddit.com/r/i3wm/. All content here is read-only.
Ask Your Question
0

i3 quits when Randr outputs change

asked 2013-02-01 09:11:58 +0000

anonymous user

Anonymous

updated 2013-02-01 09:39:02 +0000

Hello,

my laptop sits in a docking station with the lid closed and two external monitors connected. When I remove it from the dock an automated script would disable the external monitors and activate the laptop monitor.

This works well for e.g. xmonad and others. However, i3 would quit this message:

i3: No usable outputs available.

This is very inconvenient, since I lose my whole X session. Is there a way to fix this?

Thanks and Wishes!

[Edit] For clarification: Due to limitations of xrandr I have to run two separate commands:

 xrandr --nograb -d :0.0 \
        --dpi 96 \
        --output LVDS1 --auto --primary \
        --output HDMI2 --off
 xrandr --nograb -d :0.0 --output HDMI3 --off

[/Edit]

edit retag flag offensive close merge delete

1 answer

Sort by » oldest newest most voted
0

answered 2013-02-01 09:24:04 +0000

Michael gravatar image

updated 2015-10-11 10:25:04 +0000

Yes, instead of running two commands, e.g.:

xrandr --output LVDS1 --off
xrandr --output HDMI1 --auto

Run it in one command:

xrandr --output LVDS1 --off --output HDMI1 --auto

To answer your updated question:

No, there is no sane way to fix it, see https://github.com/i3/i3/issues/926

edit flag offensive delete link more

Comments

Hi, thanks for your hint. I've updated the question, because I did not point out clearly enough, that I have to use two separate xrandr commands. (xrandr would not let me change all three outputs at a time, at least when I tried last.)

jrk gravatar imagejrk ( 2013-02-01 09:36:00 +0000 )edit

Updated my answer. Note that the commands you provided should always leave LVDS1 enabled, right? i3 won’t quit then.

Michael gravatar imageMichael ( 2013-02-03 12:57:18 +0000 )edit

Thanks for your update. The bug represents exactly my problem. To be more precise, LVDS1 is not enabled. This is due to hardware limitations. I'm trying this on an X220 with a docking station. However, the internal Intel GPU can only handle two outputs at once, the other one stays off. Therefore..

jrk gravatar imagejrk ( 2013-02-03 13:59:32 +0000 )edit

Therefore.. I have to enable one external output, disable LVDS1 then and then enable the second external output. I hope the problem is clear now. :) My apologize for not being precise enough from the beginning!

jrk gravatar imagejrk ( 2013-02-03 14:03:30 +0000 )edit

But then you _also_ have at least one output enabled all the time. I still don’t see it.

Michael gravatar imageMichael ( 2013-02-04 07:16:16 +0000 )edit

Question Tools

1 follower

Stats

Asked: 2013-02-01 09:11:58 +0000

Seen: 706 times

Last updated: Oct 11