The i3 FAQ has migrated to All content here is read-only.
Ask Your Question

Shortcuts not working on non-English layouts

asked 2013-04-21 12:39:28 +0000

tab3 gravatar image


If I change keyboard layout with setxkbmap uk (or any non-English layout) all i3 and all other shortcuts get broken. Even Ctrl+D not passed to the terminal.

What is the right way to change keyboard layout?

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted

answered 2013-04-21 12:46:00 +0000

Michael gravatar image

The right way is to change your layout, delete your config, then run i3-config-wizard to generate a new one based on your layout.

If you frequently switch layouts, the other option is to use bindcode instead of bindsym and not use keysyms (that change with layouts) in your config at all.

edit flag offensive delete link more

answered 2013-04-24 18:34:14 +0000

tab3 gravatar image

The problem was not with i3 itself but rather with setxkbmap options. Working solution for multiple layout would be to include the following line in ~/.i3/config:

exec setxkbmap -option grp:alt_shift_toggle "us,ua" -option grp_led:caps

Also, a Ruby script to get current language (e.g. to display in i3 bar):

def lang
  case `xset -q | grep -A 0 LED | cut -c59-67`
  when /^0+$/
  when /1/
edit flag offensive delete link more

Question Tools


Asked: 2013-04-21 12:39:28 +0000

Seen: 1,137 times

Last updated: Apr 24 '13