The i3 FAQ has migrated to All content here is read-only.
Ask Your Question

ssh problem

asked 2013-08-13 07:53:16 +0000

anonymous user


I've installed i3 (ver. 4.2) and i have gnome3 too but when i logged in to i3 and want to connent to ssh server, ssh can't find public keys and prompt me to enter the password. but in gnome3 every thing is ok and work.

edit retag flag offensive close merge delete

2 answers

Sort by » oldest newest most voted

answered 2013-08-17 21:54:56 +0000

DocOC gravatar image

updated 2013-08-17 21:56:23 +0000

I don't know how you generated your keys, but if you did it with ssh-keygen, then wm / de should have no effect on it at all. In your home directory, do you have the file .ssh/ If not, you can generate a key which is not tied to any particular environment by running ssh-keygen, and just accepting all the defaults. You will then have your public key in $HOME/.ssh/ cat the contents of that file, and copy it into your clipboard. connect to your remote host, and then append that key to $HOME/.ssh/authorized_keys.

edit flag offensive delete link more

answered 2013-08-13 08:09:19 +0000

Michael gravatar image

I can’t provide a perfect answer to this one, but the problem is most likely a missing SSH agent or GNOME keyring or something like that :).

edit flag offensive delete link more

Question Tools


Asked: 2013-08-13 07:53:16 +0000

Seen: 454 times

Last updated: Aug 17 '13