The i3 FAQ has migrated to All content here is read-only.
Ask Your Question

i3status on secondary monitor only?

asked 2013-10-16 08:15:25 +0000

Greymon gravatar image

updated 2013-10-16 11:05:30 +0000

I'm using a setup with dual portrait displays, and I'm wondering if there is a way to have i3status on the 2nd display only. Having the same thing displayed twice makes it look cluttered, not mention it's redundant. Here's what my bar section looks like:

bar { mode dock position top font pango: cure 10 workspace_buttons yes tray_output none status ~/.i3./ }

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted

answered 2013-10-16 09:39:47 +0000

updated 2013-10-16 09:44:22 +0000

You can use output [output name] in the bar section of your i3 config file to specify where the bar should be shown. See i3 user's guide, section 5.6

Edit: Okay, this way also the workspace buttons are removed. If you don't want that but just remove the status bar, just create a second bar section in the config without a status command, c.f. the complete example in section 5.6 of the user's guide.

edit flag offensive delete link more


This actually highlights another issue I've been having. xrandr lists my monitor outputs as DVI-I-2 and DVI-I-3, but i3 doesn't accepts that as correct, and thus I can't put my bar on a single monitor. What am I doing wrong?

Greymon gravatar imageGreymon ( 2013-10-16 10:07:16 +0000 )edit

what do you mean by "doesn't accept that as correct"? It just doesn't work, or do you get some kind of an error? Sure you wrote it correct? I think there are people here that are working with devices exactly named like yours...

mschaefer gravatar imagemschaefer ( 2013-10-16 10:18:00 +0000 )edit

Sorry, I'm really bad at troubleshooting. When I use output DVI-I-3 in the bar section and reload i3, i3bar disappears. I can still move between workspaces, but the bar is gone entirely. I've tried DVI-I-2, as well, with same results, as well as DVI2 and DVI3.

Greymon gravatar imageGreymon ( 2013-10-16 10:30:01 +0000 )edit

Could you post the bar sections of your config in your initial post? Could be helpful

mschaefer gravatar imagemschaefer ( 2013-10-16 10:54:43 +0000 )edit

Could you check if you have `force_xinerama yes` somewhere in your config? In that case the outputs would be named `xinerama-0` and `xinerama-1` no matter what `xrandr` says. This was [needed for older nVidia drivers]( and you may no longer need it.

Adaephon gravatar imageAdaephon ( 2013-11-05 11:49:55 +0000 )edit

Question Tools


Asked: 2013-10-16 08:15:25 +0000

Seen: 1,127 times

Last updated: Oct 16 '13