The i3 FAQ has migrated to All content here is read-only.
Ask Your Question

How can I use i3 with multiple graphic cards

asked 2012-08-06 21:55:25 +0000

anonymous user


I have a triple monitor setup, with 2 monitors connected to 1 graphic card, and the 3rd monitor connected to a second graphic card (both nvidia, using the 302.17 binary driver).

I've disabled xinerama and am not using the force_xinerama configuration directive, because that turns the first two screens into 1 large workspace, which isn't ideal.

Here's my xrandr output:

$ xrandr --screen 0 [...] VGA-0 connected 1080x1920+1080+0 left (normal left inverted right x axis y axis) 509mm DVI-I-1 connected 1080x1920+0+0 left (normal left inverted right x axis y axis) 509mm x

$ xrandr --screen 1 [...] DVI-I-1 connected 1280x1024+0+0 (normal left inverted right x axis y axis) 376mm x 301mm

When I startx, i3 creates two workspace - one on each of the first two monitors, but nothing shows up on the 3rd monitor except for the background image. I can mouse around the 3rd monitor, but it does not have an active workspace (I cannot run applications in it).

This works with other WMs, though, where the 3rd monitor gets its own separate Xsession (at least, I think that's what's happening). For instance, with XFCE4 the 3rd monitor has its own panel and although I cannot move windows between the 3rd and either of the first two monitors, it is still a fairly nice and useable setup.

It'd be great if this would work with i3 - multiple-monitors on multiple-graphics cards is too nice a feature to give up.

edit retag flag offensive close merge delete


i have the same question... :S

c1b3rh4ck gravatar imagec1b3rh4ck ( 2012-08-12 18:43:05 +0000 )edit

1 answer

Sort by » oldest newest most voted

answered 2012-08-21 13:17:00 +0000

Michael gravatar image

As you mentioned, you need to start multiple instances of i3 in your ~/.xsession, such as:

DISPLAY=:1 i3 &
exec i3

(untested, but you should get the idea)

Also, using force_xinerama does not turn multiple screens into one big workspace — only if you have not setup the nvidia driver correctly.

You could also try upgrading the nvidia driver. Starting from version 302.17 it supports XRandR.

edit flag offensive delete link more


thanks,thats it all .

c1b3rh4ck gravatar imagec1b3rh4ck ( 2012-12-21 22:05:49 +0000 )edit

Question Tools

1 follower


Asked: 2012-08-06 21:55:25 +0000

Seen: 1,367 times

Last updated: Aug 21 '12