The i3 FAQ has migrated to All content here is read-only.
Ask Your Question

feh on all workspaces

asked 2014-07-03 16:20:48 +0000

updated 2014-07-06 11:40:12 +0000

When on my Raspberry Pi (Raspbian) with i3dm I use feh as my image viewer in Fullscreen mode (feh -F), it appears fullscreen on ALL my workspaces, thus blocking me from doing other stuff. It appears to be, on the other hand, only actually active in the workspace it was activated in (or assigned to), since exiting feh only works when switched to the corresponding workspace. Using feh in any other mode or on any other dm (Ubuntu XFCE and i3dm, OpenSUSE13.1 KDE and i3dm) works as expected. Since I use feh on every computer around and never experienced anything funny before, I suspect it to be something in the Raspberry Pi / i3 configuration. Anyone?

edit retag flag offensive close merge delete


Did you try to toggle fullscreen with i3's toggle fullscreen ability, Mod+F by default

joelmo gravatar imagejoelmo ( 2014-07-04 10:28:52 +0000 )edit

Hi joelmo, Yes I tried that but that doesn't do anything. I got some output however, when trying this from a terminal: feh WARNING: Window Manager does not support MWM hints. To get a borderless window I have to bypass your wm. There you are. So the wm is bypassed. Can this be solved?

Maestraccio gravatar imageMaestraccio ( 2014-07-04 19:54:17 +0000 )edit

In the meantime I have been puzzling a bit and found a workaround that may point to a solution: Starting fullscreen from feh (feh -F) will bypass the wm, but starting feh normally and using fullscreen from i3 ($mod+f) works. It has trouble going DIRECTLY to fullscreen though, new pics start tiled.

Maestraccio gravatar imageMaestraccio ( 2014-07-06 11:38:16 +0000 )edit

mmm in my case (i3 4.7.2) feh -F only appears in current workspace. I can move to other workspaces without problems. What is your version?

tigrezno gravatar imagetigrezno ( 2014-07-07 18:12:32 +0000 )edit

1 answer

Sort by ยป oldest newest most voted

answered 2014-07-06 20:40:27 +0000

Michael Rose gravatar image

You can make all feh instances automatically fullscreen by adding this to your config file

for_window [class="Feh"] fullscreen

edit flag offensive delete link more


You didn't read the question carefully.

ANOKNUSA gravatar imageANOKNUSA ( 2014-07-06 20:51:15 +0000 )edit

I think your response is vague and not helpful. I DID read the question. Running feh -F is broken in his/her configuration although it seems not to be so on my end as feh -F runs fine for me, my solution will enable feh to "go DIRECTLY to fullscreen" as Maestraccio stated he/she wanted.

Michael Rose gravatar imageMichael Rose ( 2014-07-06 21:14:59 +0000 )edit

Question Tools


Asked: 2014-07-03 16:20:48 +0000

Seen: 334 times

Last updated: Jul 07 '14