The i3 FAQ has migrated to https://www.reddit.com/r/i3wm/. All content here is read-only.
Ask Your Question
1

Can't set i3-sensible-terminal to terminology

asked 2014-10-26 21:39:03 +0000

Deus Deceit gravatar image

How can I set the i3-sensible-termianl to terminology? I tried setting that var trhough terminal/configuration files (e.g .profile) and even tried setting: set $TERMINAL terminology in .i3/config file... nothing worked. What do I have to do?

edit retag flag offensive close merge delete

2 answers

Sort by » oldest newest most voted
2

answered 2014-10-26 21:45:33 +0000

Michael gravatar image

Set TERMINAL before starting i3, e.g. in your ~/.xsession if you start i3 from ~/.xsession.

You could also just replace all calls to i3-sensible-terminal with terminology directly, since i3-sensible-terminal has no other function than to find a working terminal emulator.

If you’re on Debian (or derivatives), you can also use update-alternatives --config x-terminal-emulator to set the default terminal emulator.

edit flag offensive delete link more

Comments

Yup, that did it, about `update-alternatives` tho... I'm using Arch Linux and it doesn't recognize that as command. Thanks

Deus Deceit gravatar imageDeus Deceit ( 2014-10-26 21:59:22 +0000 )edit
0

answered 2015-03-24 16:07:07 +0000

the simplest way - make a symbolic link from terminology to any other one that you don't / won't install in the same place (/bin/). ye'r welcome! :)

edit flag offensive delete link more

Question Tools

Stats

Asked: 2014-10-26 21:39:03 +0000

Seen: 831 times

Last updated: Mar 24