The i3 FAQ has migrated to All content here is read-only.
Ask Your Question

color_separator customization not taking

asked 2014-11-27 23:47:53 +0000

thorin gravatar image

updated 2014-11-28 01:06:06 +0000

Adaephon gravatar image

I've customized the value of color_separator in my /etc/i3status.conf to make it easier to see, but it won't take effect when I restart or reload. Here's what I have exactly:

general {
  colors = true
  color_separator = "#C400AD"
  #color_separator = "#FFFFFF"
  interval = 5

Do I need to move it into ~/.i3/i3status.conf, or something similar?

edit retag flag offensive close merge delete


Is there a `~/.i3status.conf` or `~/.conf/i3status/config`? These might override `/etc/i3status.conf`. Also, do any other changes in the configuration take affect?

Adaephon gravatar imageAdaephon ( 2014-11-28 01:10:19 +0000 )edit

No, there isn't either of those present on my system. Other changes do take effect, I've tinkered with the order and content of items on it before.

thorin gravatar imagethorin ( 2014-11-28 01:35:01 +0000 )edit

@airblader: No, the `#` is not interpreted as start of a comment as it is already quoted with `""`. Besides, this is the way how colors are defined in the manual, so it should be the correct syntax.

Adaephon gravatar imageAdaephon ( 2014-11-28 06:29:01 +0000 )edit

Yeah, I noticed that after posting it and deleted my comment. Not quickly enough, apparently :)

airblader gravatar imageairblader ( 2014-11-28 06:31:18 +0000 )edit

1 answer

Sort by ยป oldest newest most voted

answered 2014-11-28 06:24:09 +0000

Adaephon gravatar image

updated 2014-11-28 06:49:06 +0000

The color_separator option has no effect, if the output format i3bar is used, which is also the default. The manpage of the current development version of i3status says:

Likewise, you can use the color_separator directive to specify the color that will be used to paint the separator bar. The separator is always output in color, even when colors are disabled by the colors directive. This option has no effect when output_format is set to i3bar or none.

Unfortunately the last sentence is still missing in the last released version (2.8).

You can still configure the color of the separator in the color section of the bar configuration in ~/.i3/config (or /etc/i3/config, if you prefer global configurations):

bar {
    # [...]
    colors {
        separator #C400AD
        # [...]
edit flag offensive delete link more



But the color can at least be set in the i3 configuration, though only globally for all separators.

airblader gravatar imageairblader ( 2014-11-28 06:34:53 +0000 )edit

@airblader: Thanks for the hint, I entirely forgot about that.

Adaephon gravatar imageAdaephon ( 2014-11-28 06:41:54 +0000 )edit

Question Tools


Asked: 2014-11-27 23:47:53 +0000

Seen: 137 times

Last updated: Nov 28 '14