The i3 FAQ has migrated to All content here is read-only.
Ask Your Question

i3wm working with rdesktop

asked 2014-12-04 01:31:22 +0000

diablo465 gravatar image

once focusing on rdesktop that connects to any windows remote, the master key (left windows key) is not working for switching to other i3wm windows or workspaces. I have to use mounse to click the window or workspace to get it around. Any idea to disable windows key in the rdesktop while enable it in i3wm as master key?

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted

answered 2014-12-04 06:40:19 +0000

cee gravatar image

You can set -K flag on your rdesktop call to handle the keyboard with your host system first.

edit flag offensive delete link more


thanks, working like a charm!

diablo465 gravatar imagediablo465 ( 2014-12-04 23:12:55 +0000 )edit

This works also for `xfreerdp`. One drawback is of course, that only shortcuts that are not bound in i3 will work in the rdesktop window.

Adaephon gravatar imageAdaephon ( 2014-12-05 10:49:41 +0000 )edit

Question Tools


Asked: 2014-12-04 01:31:22 +0000

Seen: 308 times

Last updated: Dec 04 '14

Related questions