The i3 FAQ has migrated to All content here is read-only.
Ask Your Question

auto login with lxdm

asked 2012-10-15 19:51:46 +0000

flipper T gravatar image

as title.

arch wiki for lxdm suggests editing /etc/lxdm/lxdm.conf


and changing "startlxde" to eg "startxfce4" etc.

i tried "starti3", but this does not work, logging into the default xfce desktop instead.

any help appreciated.

edit retag flag offensive close merge delete

2 answers

Sort by » oldest newest most voted

answered 2012-11-13 16:53:00 +0000

Klaas gravatar image

Basically, the Arch wiki page has all the info you need: "session=/usr/bin/i3" should work, but is only a fallback. Instead, you should configure your "~/.dmrc" as suggested on the wiki with:


Since /usr/share/xsessions/i3.desktop should exist, this should set i3 as the wm for your user.

edit flag offensive delete link more

answered 2012-10-16 15:05:56 +0000

Michael gravatar image

"starti3" is not the name of a binary in /usr/bin.

Instead, and suggest that lxdm respects /usr/share/xsessions/*.desktop, so try session=i3 (there should also be an i3 entry in the session drop-down menu in LXDM).

This is all speculative since I don’t use LXDM.

edit flag offensive delete link more

Question Tools


Asked: 2012-10-15 19:51:46 +0000

Seen: 1,121 times

Last updated: Nov 13 '12