The i3 FAQ has migrated to All content here is read-only.
Ask Your Question

KDE plasma desktop notifications

asked 2015-08-14 11:57:42 +0000

ssamot gravatar image


I mostly have kubuntu working fine with i3, the only thing I cannot get to work properly are certain widgets (including notifications) that I am not sure how to tell i3 to treat them as floating by default. Anyone know a way around this?

edit retag flag offensive close merge delete


Did you use `xprop` on such a notification? Are you aware of the for_window directive?

Airblader gravatar imageAirblader ( 2015-08-14 13:07:35 +0000 )edit

1 answer

Sort by ยป oldest newest most voted

answered 2015-08-21 12:22:14 +0000

ssamot gravatar image

updated 2015-08-23 20:21:54 +0000

Adaephon gravatar image

I am answering my own question based on airblader's comment (thanks), just in case someone is interested in the future. the correct i3config for KDE looks something like this:

for_window [class="Plasma-desktop"] border none
for_window [class="Plasma-desktop"] floating enable
for_window [class="krunner"] border none
for_window [class="Kmix"] floating enable
for_window [class="Plasmoidviewer"] floating enable
for_window [class="Klipper"] floating enable, border none

You can also do this to start-stop plasma-desktop:

bindsym $mod+o exec plasma-desktop
bindsym $mod+p exec "killall plasma-desktop"

When plasma-desktop starts, a small background window will also start which you have to quit manually.

edit flag offensive delete link more


You must use `,` as command separator with criteria, as criteria only apply up to the next `;`. Unless there is a new criterion after the `;` the command there will be applied to the currently focused window, which might not be the newly created window.

Adaephon gravatar imageAdaephon ( 2015-08-23 20:21:27 +0000 )edit

Question Tools

1 follower


Asked: 2015-08-14 11:57:42 +0000

Seen: 246 times

Last updated: Aug 23