The i3 FAQ has migrated to All content here is read-only.
Ask Your Question

No wifi in i3

asked 2012-11-23 15:07:55 +0000

jockster gravatar image

updated 2012-11-23 16:09:06 +0000

I am running the latest stable version of crunchbang with a fresh version of i3 installed on top. Logging in to the default WM, openbox lets me use wifi without any issues but in i3 I can only see W: DOWN in the status bar.

Wired network works however great in i3. What should I do?

Running iwconfig outputs this:

wlan0     IEEE 802.11bg  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=20 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted

answered 2012-11-23 15:49:35 +0000

loblik gravatar image

I'm not sure what's your problem. You mean your wireless connection doesn't work or you just can't see the status of your wireless interface in i3bar?

If your connection doesn't work it's not i3 fault. You have to use network manager or wpa_supplicant and some network configuration utility. I don't know what crunchbang uses.

And if it works fine but you don't see wireless information in i3bar there are two things which can cause this.

  • you don't have right interface name in i3status.conf
  • your kernel doesn't allow to configure your card via library i3status currently uses (see this question for more info: question 218)

If you run iwconfig in termnial and it prints status of your wireless NIC then its probably the first case. Otherwise it's the second thing which is not easy to fix right now (as explained in mentioned thread).

edit flag offensive delete link more


No connection on wireless whatsoever in i3 which i3bar also confirms.

jockster gravatar imagejockster ( 2012-11-23 16:10:13 +0000 )edit

Updated my post with the result of `iwconfig`

jockster gravatar imagejockster ( 2012-11-23 16:14:46 +0000 )edit

It turned out that if I added `exec --no-startup-id nm-applet` to `~/.i3/config` wifi began working. Thank you!

jockster gravatar imagejockster ( 2012-11-23 16:47:32 +0000 )edit

Question Tools


Asked: 2012-11-23 15:07:55 +0000

Seen: 2,479 times

Last updated: Nov 23 '12