The i3 FAQ has migrated to All content here is read-only.
Ask Your Question

mod+shift+e yields "please do not run this program" on Ubuntu

asked 2014-02-02 18:48:17 +0000

anonymous user


updated 2014-02-02 18:51:08 +0000

I found on this FAQ that I can logout with mod+shift+e. When I press this, I get a dialog asking for confirmation, but when I click "yes, exit i3", another bar appears saying "please do not run this program", and I don't get logged out. I just installed i3 on Ubuntu through apt-get and haven't touched the config file yet.

Is this the preferred logout method? Should I be doing something else?

edit retag flag offensive close merge delete


This sounds like a bug with the nagbar. Please file a ticket at

TonyC gravatar imageTonyC ( 2014-02-04 17:46:02 +0000 )edit

1 answer

Sort by ยป oldest newest most voted

answered 2014-02-03 07:52:03 +0000

joepd gravatar image

The official way of logout and exit are the ones in the configuration file that i3 generates after first use. After the dialogue and confirmation, what really exits the i3 session and gets you back into your X login manager, is the command i3-msg exit.

So, to test, execute i3-msg exit in a terminal, and see if it works. If it doesn't, and there are no hints in the terminal what blocks this command to execute successfully, or in your systems logs. At any case, file a bug at Ubuntu, as there apparently is an oversight in the packaging.

edit flag offensive delete link more

Question Tools


Asked: 2014-02-02 18:48:17 +0000

Seen: 446 times

Last updated: Feb 03 '14