The i3 FAQ has migrated to https://www.reddit.com/r/i3wm/. All content here is read-only.
Ask Your Question
0

scratchpad not working on Ubuntu 14

asked 2014-10-29 23:54:03 +0000

takoinche gravatar image

updated 2014-10-31 13:27:21 +0000

Adaephon gravatar image

Hello everyone. I have Ubuntu 14.04 and everything works fine except Scratchpad. No matter what i try, nothing happens whenever i try to send a window to the Scratchpad. Like that function doesn't exists at all.

Tried i3-msg move scratchpad on console and in dmenu and it worked! However, i can't seem to get it work using key shortcuts... I've tried already

bindsym $mod+Shift+minus exec --no-startup-id i3-msg move scratchpad

and

bindsym "$mod+Shift+minus exec i3-msg move scratchpad

Recently i upgraded to 14.10 but having the exact same problem. Any idea?

Further information:

  • i3 version 4.8 (2014-06-15, branch "4.8")
  • my ~/.i3/config: pastebin.com/3uCfquwZ
edit retag flag offensive close merge delete

Comments

Did you try running `i3-msg move scratchpad` from a terminal? Any error messages from that? "No matter what i try" is a bit to vague to help tracking down the problem.

Adaephon gravatar imageAdaephon ( 2014-10-30 06:44:39 +0000 )edit

Tried i3-msg move scratchpad on console and in dmenu and it worked! However, i can't seem to get it work using key shortcuts... I've tried already "bindsym $mod+Shift+minus exec --no-startup-id i3-msg move scratchpad", bindsym "$mod+Shift+minus exec i3-msg move scratchpad".

takoinche gravatar imagetakoinche ( 2014-10-30 17:31:15 +0000 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2014-10-31 13:40:06 +0000

Adaephon gravatar image

updated 2014-10-31 13:42:03 +0000

This should work:

bindsym $mod+Shift+minus move scratchpad

(You do not need exec i3-msg)

If this does not work it may be that $mod+Shift+minus is already bound to the same key. Although i3 warns if two bindings have the same key combination it does not recognize when bindsym and bindcode point to the same key. So check if there is a line in your config that starts like this:

bindcode $mod+Shift+61

Also test if any other command works on this shortcut:

bindsym $mod+Shift+minus fullscreen

It is possible (although admittedly unlikely) that your keyboard just cannot produce this key combination (2-key rollover, 2KRO).

edit flag offensive delete link more

Question Tools

Stats

Asked: 2014-10-29 23:54:03 +0000

Seen: 255 times

Last updated: Oct 31 '14