The i3 FAQ has migrated to All content here is read-only.
Ask Your Question

wireless not showing correct information on i3status

asked 2012-09-08 03:08:04 +0000

omaciel gravatar image

For some reason my wireless always shows up as "down" in i3bar. Here's my $HOME/i3status.conf:

order += "ipv6"
order += "disk /home"
order += "run_watch DHCP"
order += "run_watch VPN"
order += "wireless wlan0"
order += "ethernet em1"
order += "volume master"
order += "battery 0"
order += "load"
order += "time"

wireless wlan0 {
        format_up = "W: (%quality at %essid) %ip"
        format_down = "W: down"

and ifconfig:

wlan0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500

Anything else I could try?

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted

answered 2012-09-11 22:22:42 +0000

Do you need root to access ifconfig stuff? (debian for example). If so, you will need to run it with root privileges.

edit flag offensive delete link more

answered 2012-09-08 10:07:00 +0000

bapt gravatar image

Can you give the whole ifconfig wlan0 output ?

edit flag offensive delete link more


$ ifconfig wlan0 wlan0: flags=4163<up,broadcast,running,multicast> mtu 1500 inet netmask broadcast inet6 fe80::a288:b4ff:fec1:7700 prefixlen 64 scopeid 0x20<link> ether ****** txqueuelen 1000 (Ethernet) RX pac

omaciel gravatar imageomaciel ( 2012-09-08 15:27:07 +0000 )edit

Hey Og, it works for me. I keep it turned off and when I turn it on, it appears in the i3bar. Can you try to turn it off and on?

lzap gravatar imagelzap ( 2012-09-12 08:27:18 +0000 )edit

Question Tools

1 follower


Asked: 2012-09-08 03:08:04 +0000

Seen: 1,398 times

Last updated: Sep 11 '12