The i3 FAQ has migrated to https://www.reddit.com/r/i3wm/. All content here is read-only.
Ask Your Question
0

HUGE font on startup

asked 2014-11-23 03:19:00 +0000

drak3 gravatar image

updated 2014-11-23 03:26:14 +0000

I've been trying to customize my config a bit. After I changed the font, I've been noticing the font size will be huge when I login with i3. We're talking at least twice as tall.

I figured out restarting i3 seems to fix it. However, this also seems to change the behavior of gnome-settings-daemon slightly (which I use for small little conveniences--nothing major), and I feel like I shouldn't have to restart the WM to have properly sized font.

I'm wondering if anyone has encountered this issue, or if they know how I might fix it? (note: the default font does not suffer this issue). the font lines from my config (one or the other would always be commented out):

font -misc-fixed-medium-r-normal--13-120-75-75-C-70-iso10646-1
font pango:DejaVu Sans Mono 10

edit:

OS: Debian 7.7 Wheezy (stable)

i3 version: 4.8

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
1

answered 2014-11-23 13:52:20 +0000

drak3 gravatar image

It would appear the issue was with my DPI settings. For some reason, the DPI would be set to some higher than actual value when i3 started. the lines I added to my configuration:

Option "DPI" "96 x 96"

Odd that the DPI would be detected by xorg properly (using xdpyinfo | grep -B2 resolution), but would not display correctly the first time...

edit flag offensive delete link more

Comments

What if you don't want to create an `xorg.conf`?

kynan gravatar imagekynan ( 2015-03-26 07:46:54 +0000 )edit

not sure. why do you want to avoid it? I think this might be an nVidia issue. I have since switched to an AMD card, and did not have the issue with a default xorg.conf

drak3 gravatar imagedrak3 ( 2015-03-26 12:29:46 +0000 )edit

Since it's a laptop I switch display configurations very frequently so it's just easier without an `xorg.conf`. I might try to just set those specific settings in a dedicated conf file in `/etc/X11/xorg.conf.d`.

kynan gravatar imagekynan ( 2015-03-26 22:29:46 +0000 )edit

Question Tools

Stats

Asked: 2014-11-23 03:19:00 +0000

Seen: 244 times

Last updated: Nov 23 '14