The i3 FAQ has migrated to https://www.reddit.com/r/i3wm/. All content here is read-only.
Ask Your Question
0

How to create shortcut for nautilus?

asked 2014-12-06 00:35:00 +0000

jefeyay gravatar image

I've set a shortcut in my .i3/config file as such: bindsym $mod+n exec nautilus --no-desktop

This works to launch one instance, however, subsequent attempts fail. The only feedback is that the indicator for that workspace shows the urgent color. Launching another instance via the i3-dmenu-desktop works fine but then it launches with desktop control.

Launching the 'nautilus --no-desktop' command at a terminal produces: * (nautilus:6210): WARNING *: Couldn't connect to accessibility bus: Failed to connect to socket /tmp/dbus-p9bGA1q0zk: Connection refused

(nautilus:6210): Gtk-WARNING **: Failed to register client: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files Initializing nautilus-dropbox 1.6.2 <gi.module.dynamicmodule 'nautilus'="" from="" '="" usr="" lib="" girepository-1.0="" nautilus-3.0.typelib'=""> Insync Nautilus Plugin <class 'insync_plugin.insyncextension'=""> ('[init insync plugin]', <insyncextension object="" at="" 0x7fe9ec02ffa0="" (uninitialized="" at="" 0x0)&gt;)<="" p="">

Nautilus still launches but the second attempt from terminal fails and produces: * (nautilus:6316): WARNING *: Couldn't connect to accessibility bus: Failed to connect to socket /tmp/dbus-p9bGA1q0zk: Connection refused

Other file managers work properly with the shortcuts but I'd like to either a: figure out where my mistake is or b: get pointed in the right direction on finding the problem

I'm using Ubuntu 14.10 as my base.

edit retag flag offensive close merge delete

1 answer

Sort by » oldest newest most voted
1

answered 2014-12-06 22:25:26 +0000

Michael gravatar image

By default, nautilus will only run one process and starting the nautilus binary again will only result in the new process telling the old one about it. This results in the existing nautilus window being raised, which you can observe when you have both of them on the same workspace, e.g. in a stacked container.

I think the solution you’re looking for is using nautilus --no-desktop --new-window, which will result in a new window being opened instead of the existing window being raised.

edit flag offensive delete link more

Comments

That's it, thank you very much.

jefeyay gravatar imagejefeyay ( 2014-12-07 00:16:32 +0000 )edit

Question Tools

Stats

Asked: 2014-12-06 00:35:00 +0000

Seen: 401 times

Last updated: Dec 06 '14