The i3 FAQ has migrated to All content here is read-only.
Ask Your Question

for_window [class=""] floating enable doesn't work

asked 2013-04-03 12:45:44 +0000

MIRAMAXED gravatar image

updated 2013-04-03 14:47:47 +0000

Hi all!
I'm install last version i3wm( 4.5.1) from repositories, and i have a problem...
for_window [class="^Pcmanfm$"] floating enable - doesn't work :-(
I do something wrong? I want to run some applications in floating mode.

edit retag flag offensive close merge delete


have you reloaded your configuration ($mod+Shift+c by default)? Because your above statement works properly for be, and I have the same 4.5.1 version from the Ubuntu repo!

mschaefer gravatar imagemschaefer ( 2013-04-03 16:43:12 +0000 )edit

yes, i trying reload configuration, but nothing work... I think "for_window" function is not work on my linux, because i also try disable border for windows using this function and nothing work. P.S. sorry for my english :)

MIRAMAXED gravatar imageMIRAMAXED ( 2013-04-03 18:26:43 +0000 )edit

please provide your config file. but also try out the default config plus the line you have posted.

vandannen gravatar imagevandannen ( 2013-04-03 19:26:01 +0000 )edit

MIRAMAXED gravatar imageMIRAMAXED ( 2013-04-03 19:38:09 +0000 )edit

1 answer

Sort by ยป oldest newest most voted

answered 2013-04-03 20:31:49 +0000

MIRAMAXED gravatar image

updated 2013-04-03 20:33:18 +0000

Now i copy new default config and it's worked! :D Thanks guys!

edit flag offensive delete link more

Question Tools


Asked: 2013-04-03 12:45:44 +0000

Seen: 456 times

Last updated: Apr 03 '13