no workspace selected after window moved to scratchpad [closed]

asked 2015-01-29 02:06:42 +0000

Pinyaka gravatar image

I am trying to launch a web browser when I start i3, but it only works sporadically. I think what's happening is that I've also got a terminal set to open with a particular name and used a for_window assignment to move it to the scratchpad. I think this is leaving no workspace selected and then the browser doesn't have a workspace to show up on, even though I open it via exec i3-msg "workspace number 4; exec google-chrome" as the last thing in my config. When this glitchy thing happens, I have to select a workspace (via the mouse as the keybindings to select one don't work either) and then open a new instance of the browser, which opens both windows. Sometimes it works just fine, which leads me to believe that there's probably a race condition.

My questions are:

  1. Is it possible to move the terminal window into the scratchpad and leave another workspace selected?

  2. Is there a better way to move the terminal to the scratchpad?

i3 version 4.8 (2014-06-15, branch "4.8") © 2009-2014 Michael Stapelberg and contributors

edit retag flag offensive reopen merge delete

Closed for the following reason not a real question by Michael
close date 2015-01-29 07:52:51.903929


You’re doing everything right, it seems. Please open a bug at

Michael gravatar imageMichael ( 2015-01-29 07:52:43 +0000 )edit

Done. Thanks for looking into it.

Pinyaka gravatar imagePinyaka ( 2015-01-29 14:55:34 +0000 )edit

deleted as irrelevant

Pinyaka gravatar imagePinyaka ( 2015-01-29 20:25:52 +0000 )edit